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1 GOALS

In this tutorial you will:

• Create a new View

• Listen for the workbench selection

• Explore the use of “IAdaptable” to allow a single selection entry 
to represent multiple values.



2 DEFINING A VIEW

We are going to use the facilities of the org.eclipse.ui plug-in to 
define a new view.

1. Open the Plug-in Development Perspective.

2. Create a new plug-in named 
net.refractions.udig.tutorials.workbench

3. Press Next to continue

Please review the  

earlier distance tool  

tutorial for detailed 

instructions on creating 

a new plug-in and 

adding dependencies.



4. This time we are going to make contributions to the UI:

5. Press Finish to create the plug-in, the MANIEST.MF file for your 
new plug-in will be opened.

6. Add the following plug-in dependencies to your MANIFEST.MF:
net.refractions.udig.project
net.refractions.udig.catalog

7. Save your MANIFEST.MF file, now that the plug-in knows about 
the dependency on org.eclipse.ui we are able to create an 
extension for the org.eclipse.ui.views extension point.

8. Switch to the Extensions tab of the Manifest editor and press the 
Add button.

9. Choose org.eclipse.ui.views from the wizard and press Finish. 

These steps make use of  

the Plug-in Manifest  

Editor; using the 

Dependencies and 

Extensions tabs



10. Select the new extension and set
ID: net.refractions.udig.tutorials.workbench.views
Name: Workbench Views

11. Right click on the new extension and select New > View

12. Take a moment to add the workbench_icons.zip to your project:
http://udig.refractions.net/files/tutorials/workbench_icons.zip   

13. Select the new operation element and set:
id: net.refractions.udig.tutorials.workbench.views.selectionView
name: Selection
class: net.refractions.udig.tutorials.workbench.SelectionView
icon: icons/etool16/workbench.png
allowMultiple:  false

14. Save your MANIEST.MF file.

15. Click on the class link to open the New Java Class Wizard

The ID and Name for 

the extension point are  

mostly used when 

reporting exceptions in  

the log.

http://udig.refractions.net/files/tutorials/workbench_icons.zip


16. Enter the following:
Name: SelectionView
Package: net.refractions.udig.tutorials.workbench
Superclass: org.eclipse.ui.part.ViewPart

17. Click the Finish button.

18. The created SelectionView class is opened for you.
package net.refractions.udig.tutorials.workbench;

import org.eclipse.swt.widgets.Composite;
import org.eclipse.ui.part.ViewPart;

public class SelectionView extends ViewPart {

public SelectionView() {
// TODO Auto-generated constructor stub

}

@Override
public void createPartControl(Composite parent) {

// TODO Auto-generated method stub

}

@Override
public void setFocus() {

// TODO Auto-generated method stub

}

}

The New Java Class  

wizard is aware of what  

you are doing and has 

filled in the ViewPart  

interface already.



3 IMPLEMENTING SELECTIONVIEW

Now that our view has been created we can carefully implement the 
following methods

1. Now that you have some template code, let us start filling it in. 
Do not worry about the constructor. The constructor is called 
when your view is opened and displayed on the screen. There is 
no need for you to do any work inside of it.

public SelectionView() {
//don't put anything in here

}

2. Create an init method to load in any settings from the previous 
run.
You can quickly override methods by pressing Control-Space on 
any blank line and choosing the method you wish to implement 
from the provided list.

@Override 
public void init( IViewSite site, IMemento memento ) throws 
PartInitException {

super.init(site, memento);
}

3. The init method is called when your plugin is going to be used; 
and it provides two valuable pieces of information:

• IViewSite: is a utility class used to access workbench 
resources such as the status line or workbench window. You 
can retrieve the IViewSite at any point after the init method 
by using getViewSite()

• IMemento: is used to hold on to information (usually 
provided by the user) between runs.



4. The next method is in charge of making a user interface; the 
provided parent “widget” has been created for our use (we can set 
the layout and create any child widgets as needed).

private Text text;
private Text description;
@Override
public void createPartControl( Composite parent ) {
parent.setLayout( new GridLayout(2,false) );
    Label label = new Label(parent, SWT.RIGHT );
    label.setLayoutData(new GridData(SWT.RIGHT,SWT.TOP,false,false));
    label.setText("Selection:");
    text = new Text(parent, SWT.DEFAULT | SWT.READ_ONLY );
    text.setTextLimit(70);
    GridData gridData = new GridData(SWT.FILL,SWT.FILL,true,false);
    text.setLayoutData( gridData );

    label = new Label(parent, SWT.RIGHT );
    label.setLayoutData(new GridData(SWT.RIGHT,SWT.TOP,false,false));
    label.setText("Content:");
    description =
         new Text(parent, SWT.V_SCROLL | SWT.H_SCROLL | SWT.MULTI );
    gridData = new GridData(SWT.FILL,SWT.FILL,true,true );
    gridData.widthHint = 500;
    gridData.heightHint = 200;
    description.setLayoutData( gridData );
    //LISTEN TO WORKBENCH
}

5. You can use Control-Shift-O to sort out the required imports.

6. We are going to create a selection listener to watch the 
workbench for us.
You can create this inner class at the top of the file before the 
constructor.

private final class WorkbenchSelectionListener implements 
ISelectionListener {
    public void selectionChanged( IWorkbenchPart part,
                                  ISelection selection ) {
        if( selection instanceof IStructuredSelection ){
            updateSelection( (IStructuredSelection) selection );
        }
        else {
            updateSelection( null );
        }
    }
}
private ISelectionListener selectionListener;

7. We can now add our code to “listen to the workbench” to the 
createPartControl method.

    selectionListener = new WorkbenchSelectionListener();
    ISelectionService selectionService =
            getViewSite().getWorkbenchWindow().getSelectionService();
    selectionService.addPostSelectionListener(selectionListener);

8. You can see how the getViewSite() method is used to look up and 
make use of eclipse RCP facilities.



9. Although we do not use it in this tutorial, we could assign focus 
to one of the controls if we were excepting input. If we did, it 
would be something like: description.setFocus()

@Override
public void setFocus() {

//this is where we would put stuff
}

10. It is good practice to clean up after any resources used (things 
such as  widgets, colors, images and fonts). You should always be 
careful with null checks and never assume that createPartContrtol 
has been called.

@Override
public void dispose() {
    if( selectionListener != null ){
        // if our init method failed selectionListener would be null!
        //
        ISelectionService selectionService =
            getViewSite().getWorkbenchWindow().getSelectionService();
        selectionService.removePostSelectionListener(
            selectionListener
        );
        selectionListener = null;
    }
    super.dispose();
}

11. Now that we know something is happening we can quickly 
inspect the value.

protected void updateSelection( IStructuredSelection selection ) {
    if( selection == null || selection.isEmpty() ){
        text.setText("(nothing is selected");
        return;
    }
    Object object = selection.getFirstElement();
    if( object == null ){
        text.setText("(selected object is null)");
        return;
    } else {
        text.setText( object.toString() );
    }
    // DESCRIBE
}

12. The IStructuredSelection is used to return multiple values; the the line 
above we are checking if the first element is non null. When it comes 
time to describe the selection we will iterate over all the contents.



13. We can continue to examine the value; producing a description based 
on what kind of interfaces the Object supports.
We are performing this check with a simple “instance of” that will 
return true of the provided object implements the interface or class 
mentioned.

    // DESCRIBE
    StringBuffer buffer = new StringBuffer();
    String separator = System.getProperty("line.separator");
    for(Iterator<?> iterator=selection.iterator();
        iterator.hasNext(); ){
        
        object = iterator.next();
        buffer.append( "VALUE: ");
        buffer.append( object.toString());
        buffer.append(separator);
        buffer.append("==========================");
        buffer.append(separator);
        // from net.refractions.udig.project
        if( object instanceof IMap ){
            buffer.append("instance of Map");
            buffer.append(separator);                
        }
        if( object instanceof ILayer ){
            buffer.append("instance of ILayer");
            buffer.append(separator);                
        }
        // from net.refractions.udig.catalog
        if( object instanceof IService ){
            buffer.append("instance of IService");
            buffer.append(separator);                
        }
        if( object instanceof IGeoResource){
            buffer.append("instance of IGeoResource");
            buffer.append(separator);                
        }
        // from org.geotools
        if( object instanceof Filter ){
            buffer.append("instance of Filter");
            buffer.append(separator);                
        }
        if( object instanceof Feature ){
            buffer.append("instance of Feature");
            buffer.append(separator);                
        }
        // IADATABLE
    } // NEXT
    description.setText(buffer.toString());
}

14. Up until this point we are working with Java objects using normal 
java syntax. An object can support multiple interfaces (each 
representing a different API used to interact with the object) but 
the choice of what API to implement has been made at compile 
time.



15. Eclipse also has the facility to support additional interfaces at runtime 
using IAdatable.

        // IADATABLE
        buffer.append("--------------------------");
        buffer.append(separator);     
        if( object instanceof IAdaptable){
            // IAdtable is a magic interface that allows
            // a single object to return multiple interfaces
            IAdaptable adaptable = (IAdaptable) object;
            if( adaptable.getAdapter(IMap.class) != null ){
                buffer.append("adapts to Map");
                buffer.append(separator);                    
            }
            if( adaptable.getAdapter(ILayer.class) != null ){
                buffer.append("adapts to ILayer");
                buffer.append(separator);                    
            }
            // from net.refractions.udig.catalog
            if( adaptable.getAdapter(IService.class) != null ){
                buffer.append("adapts to IService");
                buffer.append(separator);                    
            }
            if( adaptable.getAdapter(IGeoResource.class) != null){
                buffer.append("adapts to IGeoResource");
                buffer.append(separator);                    
            }
            // from org.geotools
            if( adaptable.getAdapter(Filter.class) != null ){
                buffer.append("adapts to Filter");
                buffer.append(separator);                    
            }
            if( adaptable.getAdapter(Feature.class) != null ){
                buffer.append("adapts to Feature");
                buffer.append(separator);                    
            }
            if( adaptable.getAdapter(URL.class) != null ){
                buffer.append("adapts to URL");
                buffer.append(separator);                    
            }
        }
    } // NEXT
    description.setText(buffer.toString());
}

16. You can see that the getAdapter works in a similar manner to an 
instance of check; returning non null if the object can be 
“adapted” into the requested interface.



4 RUNNING YOUR CODE 

We can now run uDig and try out your new plug-in:

1. Select Run > Open Run Dialog... from the menu bar and choose 
the configuration you set-up in the previous tutorial. Be sure to 
add your new plug-in to the list.

2. Once uDig is up and running select the following from the main 
menu across the tope: Window > Show View > Other... to open 
the Show View dialog.

3. Expand the one folder labelled Other and click on Selection and 
press OK.

4. You should now see a view like the one below.

5. Try opening a Map, and adding several layers to it. Switch 
between the different Map Tools. As you try these activities 
watch the information displayed about the current selection.



6. The information displayed offers a breakdown of the item that 
you selected, any interfaces it implements, and a record on if it 
can be adapated into anything useful.

7. In the example above a country has been selected. A single 
selection is provided that is an instanceof “Filter” (a geotools 
class used to perform a query). This filter has the ability to adapt 
to a Layer is asked (presumably the layer containing the data).

Our single selected Object capable of speaking two Java APIs; 
the Interfaces it was compiled with; and the Interfaces it can be 
adapted to.



5 THINGS TO TRY

Here are some additional challenges for you to try:

• Each View provides a unqiue selection; the Map Editor will 
change what selection it provides based on the current tool.

• Currently, if you want to see the workbench view you have to 
select Window>Show View>Other to open a the Show view 
dialog. You can then use the Show view dialog to navigate to 
Other >Select View.

Can you use a perspective extension make your view show up 
under the main view menu?

• We have focused on listening to the workbench selection. Can 
you use getViewContext() to advertise an object to the 
workbench selection service?
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