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1 Introduction

In this workbook we are going to cover two major topics. The first is a tour of Web Feature 
Server functionality using a local GeoServer installation. We will use a WFS to edit both 
feature geometry and feature attributes. We will also show how to export information out of  
a WFS using both a local shape file and the system clip board.

The rest of the workbook is devoted to working with information. We will create a new 
feature type by hand, and work with a range of feature creation and editing tools. Finally we 
will save the result to a new file.
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As we went to  
Press GeoServer 
2.0.1 was tested 
and working.



2 WMS and WFS Integration

In this section we will use uDig to display contents from our local Web Feature Server. We 
will also make use of some of the more interesting selection features.

1. Start uDig, under the File menu select  New-> New Map to create a new map.

2. Make sure your local GeoServer is started and ready to go. You can run GeoServer from 
the Start menu.

3. Navigate to that GeoServer Welcome page:
http://localhost:8080/geoserver/

4. Drag and Drop the WMS 1.1.1 Capabilities link on to your Map.
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If you were 
unable to get  
GeoServer 
installed please 
ask the 
instructor for  
help, we may be 
able to provide a  
URL to a demo 
machine

IE9 and Opera 
do not support  
drag and drop.

If using a 
browser that  
doesn't support 
drag-and-drop 
copy the link,  
selecting the 
Catalog, Layer  
or Map view and 
Paste.

http://localhost:8080/geoserver/


5. This will bring up a Wizard allowing you to choose which Layers you wish to see.  Select 
Tasmania state boundaries and Tasmania cities and the press the Finish button.

6. Move tasmania_cities_Type to the top of your layers view.

7. Drag and Drop the WFS 1.0.0 Capabilities link on to your Map.
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We are using 
WFS 1.0 in order  
to have read-
write access to 
GeoServer.



8. This will bring up a Dialog allowing you to choose which Layers you wish to see.  Select 
Tasmania roads and Tasmania water bodies and press the Finish button.

9. Select the Map in the projects view and choose File->Rename menu item.

10. Rename to Tasmania.
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You may wish to 
adjust the styles 
so that lakes are  
blue as shown 
in the picture.



11. You can compare your map with what is shown by GeoServers layer preview for the 
Tasmania layer.
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3 Editing Geometry with WFS

We will use the Edit Geometry tool to move the road around the lake.

1. Zoom into the road that is crossing the lake in the center of the country

2. Select tasmania_roads_Type in the Layers view.

3. Change to the Edit Geometry tool from the tool palette
(click the Editing drawer to see the available editing tools).

4. Use the Edit Geometry tool to select the road crossing the lake.

5. The road will change color and develop “vertex handles”.
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You can use the 
keyboard short-
cut ‘e’ to choose 
the edit tool



6. Move the vertex handles so the road does not enter the water.

7. Add new vertices by switching to the Add Vertex tool.

8. You can click any where on the road to add a new vertex.

9. You can use Undo and Redo in the Edit menu as required.

10. Press the Commit Changes button in the tool bar to send your changes off to the Web 
Feature Server.

11. Your line has now been moved.
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By default no 
snapping takes 
place. We will  
show how to 
turn on snapping 
later in this 
workbook.

You may also 

press Revert (
 in the tool bar)  
to rollback any 
changes you 
have made.

You can cycle 
through the 
available edit  
tools by pressing 
“e”.



12. You can now refresh your web page to confirm that your changes have been made.

13. You can edit many Features at once, from different layers, or from different sources of 
data. Pressing Commit Changes will send off all the changes made in the current map.
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4 Working with Attributes

In this section you will learn how to edit an Attribute, along the way we will explore the use 
of styling.

To start out with lets figure out the name of that city:

1. Select Navigation > Show All from the menu bar.

2. Select the Tasmanian cities in the Layers View.

3. Select the Edit > Delete command from the menu bar

4. In the Catalog view expand the GeoServer Web Feature Service (WFS 1.0.0) entry 
and select  Tasmania cities.

5. Right Click and select  Add to Current Map.

6. Right click on Tasmania cities in the Layers view, and click on Change Style.

This opens the Style Editor dialog.
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7. Define the point shape using style as follow:

• Select the Points page from the list on the left hand side of the Style Editor.

• Choose Simple Style to access the the built in shapes.  

• Choose circle from the list of built in shapes.

8. Configure the style properties for labeling:

• Click on the Labels tab

• Check the enable/disable labeling

• Choose CITY_NAME for the label property.

9. After making changes, hit the Apply button to update the map, you can experiment with 
the settings and press Close when you are finished.
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10. Ensure that  Tasmania cities is still selected in the layers view, and select the Table 
view.

11. The first time you use table view you will need to accept a warning that all the features 
will be loaded into memory.  

12. The Table view shows all the features for the current layer.

13. Go ahead and rename the city after yourself. Change the CITY_NAME attribute and you 
can watch the map update.

14. Press the Commit Changes button, in the tool bar, to send your changes off to the Web 
Feature Server.
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Not all aspects of  
a feature are 
editable. -  
bounds are 
derived from the 
geometry, and ID 
is dictated the 
WFS.



5 Exporting to Shape fle

In addition to editing content from many sources, you can also export content to a shapefile.

1. With Tasmania roads selected, choose File > Export from the menu bar

2. Select the Resource to Shapefile and press Next

3. Your Tasmania roads layer will be available for export, you can see that it is in the 
“WGS84” projection.

4. Press Finish to save the file to disk.
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The projection 
for your data is  
listed to the right.  
Click on this  
value to 
transform your 
data into a 
different  
projection.

Exported files are  
added to the 
catalog.



6 Take a Break!

Wow that was a lot of content, lets take a break and go over some ideas you can try at 
home.

• The OpenLayers application also include the ability to edit, see if you can edit something 
in the browser and get the change to show up in uDig.

• There are additional Web Feature Servers listed in the Web Catalog. Try downloading 
some content and seeing what you can learn.

Okay lets move on.
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7 Creating Feature Type

We are going to create a new feature type to experiment with some of the more interesting 
edit tools.

1. Create a New Map

2. Rename the map to “New Tasmania”

3. Add the  “tasmanian roads.shp” file you created previously. You can drag and drop the 
file onto the map, or use Layer > Add from the menu bar.

4. Select the Layer -> Create command from the menu bar.

5. Replace “New Feature Type” with “Lake”.

6. Change the type of the “the_geom” attribute to MultiPolygon.
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Ctrl+L followed by 
C will also open 
the Create 
Feature Type 
dialog.

If you have a 
shapefile selected 
you will see 
“the_geom”; the 
default attributes 
are based on the 
current selection.



7. Click Add Attribute button.

8. Select your new attribute and change the Type to “ Integer” and the Name to “type”

9. Press OK button

• Your layer has been added to the current map

• Your data has been added to the Scratch area of the catalog
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8 Copying Content

Now that we have created a new feature type, we can use cut and paste to grab geometry 
content from our WFS. This is different from the export we did earlier in that we are using 
our layer type.

1. Change to Tasmania map and select  Navigation->Zoom AOI in the menu bar.

2. In the Layers view make sure that  tasmania_water_bodies_Type is selected as shown 
below.

3. Select Box Selection from the tool palette.

4. Use the Box Selection tool to draw a box around all the lakes. The lakes will change 
color when selected.
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Press “S” to use 
the select tool at  
any time.



5. Select Edit->Copy from Edit menu. These lakes will be placed onto the clipboard.

6. Switch over to the New Tasmania map. Ensure your select Lake layer is selected in the 
layer view, and right-click mouse button to select  Paste.

7. Press commit to write these new features into your Scratch layer.  
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You can paste 
geometry into 
other 
applications as 
either GML or  
WKT.



9 Hole Cutter

In this section we will cover how to create a hole in a polygon.

1. Open the New Tasmania map and zoom to lake shown below.

2. Open the Editing drawer of the Palette to show all the edit geometry tools. Select the 
Hole Cutter tool from the tool palette.
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You can use the 
keyboard short-
cut ‘e’ to cycle  
between the edit  
tools.

Additional editing 
tools supplied by 
the community 
are available.



3. Use the hole cutter to draw a polygon within the lake.  

4. Press Enter, or click on the first vertex, to create the island.

5. Press the Commit button in the toolbar.
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You can press 
Esc to cancel  
your edit.



10Create Geometry

The second category of tools involves creating geometry, we will cover line and polygon 
creation and “vertex snapping”.

1. Select tasmanian roads in the layer view.

2. Choose the Create Line Tool from the Create drawer of the Palette. 

3. Draw a road on the northern part of the island, once again Enter to indicate that you are 
finished your line.

4. You have just created a new road, remember to press commit in the tool bar to write 
your change to the shape file.

5. Change to the Lake layer in the layer view.
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Use the keyboard 
short-cut ‘c’ to  
cycle between the 
create tools.



6. Select the Create Polygon Tool.

7. Enable snapping by pressing CTRL+SHIFT+S until Snap to features in current layer is 
displayed in a dialog.

8. Draw a polygon, close to a feature, as you draw close to another polygon you can watch 
how snapping effects the drawing process.

9. You can complete your polygon by ending it on the vertex that started the polygon.

10. Please press the commit button in the toolbar.
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If you watch 
closely the last  
vertex will  
expand closely 
when you are 
about to close 
the polygon.

If you go too far 
just keep 
pressing Control-
Shift-S, it will  
cycle through all  
the snapping 
options.



11Changing Snapping Behavior

The snapping choices included with uDig are as follows:

No Snapping Snapping is turned off by default.

Selected Features Snap to a vertex in a selected feature.

Current Layer Snap to a vertex in the current layer

All Layers Snap to a vertex in any layer

Grid Snap to the nearest grid intersection

There are three different ways to change the snap behavior:

1. In the Edit Tool Preferences   which can be found in the Window > Preferences menu.

2. While an edit tool is active press CTRL+SHIFT+S. This will cycle through the available 
snap behaviors. A small pop-up will display the new behavior.

3. You can see a short cut of the tool snapping options in the tool options along the bottom 
of the map.
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http://127.0.0.1:64783/help/topic/net.refractions.udig.help/html/Edit%20Tool%20Preferences.html


12Delete Feature Tool

1. To delete the feature just created select the Delete Feature Tool in the tool palette.

2. Click on the newly created feature and it will be deleted.
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13Fill Tool

The Fill tool fills spaces that are not occupied by existing features.

1. Select the Fill Area Tool.

2. Draw a Polygon that goes through some existing features.

3. Change to the select tool and click on the Polygon to select it. This is in-fact a multi  
polygon; a single feature made up of separate shapes on the map.
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14Save 

We are now going to save the “Scratch” layer we have been working with.

1. Please press the Save button in the tool bar (or choose save from the File menu).

2. Ensure that your scratch layer Lake is selected and press Finish.

3. A new shapefile has been created in the directory indicated, you can see this file in your 
catalog.

4. Your map has been updated to use your new layer, you can verify this by right clicking 
on your Lake layer and checking its Properties.
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15What to Do Next

Where to go from here? Try out the following:

• You can use the Reshape operation reorder and rename attributes and even create new 
ones using simple formulas

• Enable Advanced Editing Tools in Windows > Preferences and see what ideas the 
developers are considering. You will need to close and open your map for the settings to 
take effect.

• The uDig community site has additional editing tools.
Try out the tools provided by Axios.
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Look at the 
“Common Query 
Language” in the 
online help for a 
complete function 
list.
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