
There and back again

Using uDig to perform real world tasks

Foss4G 2008 Lab

Version Date Auteur(s) Etat

1.0 16.09.2008 JER Valide

© 2008 camptocamp SA – Lausanne, Suisse. Ce document est propriété de 
Camptocamp SA et ne peut être copié, reproduit par quelque procédé que ce soit, 
utilisé ou transmis à des tiers sans autorisation écrite préalable de Camptocamp SA. 



  Foss4G 2008 uDig Lab

1.0 / 16.09.2008 / JER   2/3
© 2008 camptocamp SA / 



Table of Contents

...................................................................Introduction
 4

...........................................................Introducing uDig
 5
...........................................................................................Add Postgis Layer
 5

.....................................................Add Data Using Embedded Web Browser
 8

...........................................................................................Add raster layers
 13

......................................Adding functionality to uDig
 17

..........................................................Fixing your data
 22

.....................................................Looking at animals
 28
...................................................................................................Lots of style
 29

................................................................................Exploring the table view
 31

...................................................................Axios tools (Spatial operations)
 34

......................................................................Postgis and copying features
 40

...........................................................................................Custom Graphics
 44

......................................................................Converting Polygons to Lines
 46

................................................Adding new attributes
 48

....................................Appendix I -- CQL Resources
 51

  Foss4G 2008 uDig Lab

1.0 / 16.09.2008 / JER   3/3
© 2008 camptocamp SA / 



1 Introduction

Two of the main reasons to use a Desktop GIS application rather than a Rich Internet 
Application like MapFish or CartoWeb are:  Better desktop integration and extra 
processing power provided by desktop (or laptop) computer.  This workshop aims to 
introduce some of the features of uDig that differentiates it from other applications.

Topics covered will include 
• Constructing maps from local and web-based sources.
• Editing the vector data.  
• Feature Buffering and layer intersection
• SLD styling basics
• Copying data between services, for example copying features between shapefiles, 

Web Feature Servers and PostGIS

If this lab is too fast paced you can obtain introductory walkthoughs one the uDig 
website:  
• Walkthrough 1 -- Introduction to uDig
• Walkthrough 2 -- Introduction to Editing
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2 Introducing uDig

In this starting section we will learn various ways of constructing map with uDig.   The 
goal is to lean how to quickly and efficiently construct maps so that you can start 
performing the valuable tasks that you have been assigned.  

Add Postgis Layer
• To open the Add Data wizard, select the menu item Layer > Add 

• Select the PostGIS option and press the Next button
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• For performance we will access the postgis on the local host.  Enter the following 
connection information and press the Next button:

Host: localhost Port: 5432

Username: postgres Password: postgres

Database: postgres Schema: public

• Select sou_boundaries and press the Finish button

  Foss4G 2008 uDig Lab

1.0 / 16.09.2008 / JER   6/3
© 2008 camptocamp SA / 



• A new map should open and appear similar to the following image
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Add Data Using Embedded Web Browser

• Press the Web table placed behind the Catalog View

• Enter the path to the catalog.html file in the data directory.  (Unfortunately I donʼt know 
the path to the catalog.html at the time of this writing.)
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• Drag the link The Worldʼs Countries to the layers view.  

• The map should now look like the following(the SOU_boundaries layer is probably 
a different color)

• Notice the layer has a style already.  This is because shapefiles with an 
associated .sld file will have the style from the sld file automatically applied 
when the layer is added.

•

• Drag the SOU-level_1_UTM35 link to the map:
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• This layer will not appear in the map display because it does not have a PRJ file 
associated with it.  The layer has a decorator to indicate a potential problem with the 
layer.

• Press the Mylar button 

• Right click on the SOU-level_1_UTM35 layer and select Properties
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• Select Projection

• Enter cape into the search bar and select Cape / UTM zone 35S (EPSG:22235)

• You should see the data now is correctly repojected from EPSG:22235 to WGS 84 
(EPSG:4326)
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• Now that we have found the correct projection we need to write it to the shape file.  
(Setting on the layer only affects the layer.  Adding a new layer based on the same 
data will not have the new projection)

• Right click on the layer and select Operations > Set Projection

• Verify the correct projection is selected and press the OK button
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Add raster layers

• Drag the SOU_satellite link from the embedded web browser to the map

• The map should now appear as follows

• Next drag the image so it is the bottom layer in the map (using the layers view)
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• Press the Projection button on the map.

• Set the projection to EPSG:22235

• All layers are reprojected
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• Drag SOU-7-5 satellite to the map

• Notice that the new raster is also reprojected.  Also notice how the Mylar effect makes 
it easy to spot the newly added layer.

• Change projection back to EPSG:4326
• Turn mylar off

• The layers view should now look similar to the following

• Draw the Local Geoserver WMS link to the Layers View
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• Select Bluemarble and press the Finish button

• This adds the bluemarble layer to the top of the map.
• Move the bluemarble layer so it is the bottom layer of the map
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3 Adding functionality to uDig

The out-of-the-box installation of uDig has enough functionality to do basic tasks but for 
more complex tasks there are plugins that can be installed to assist in performing these 
tasks.  This section shows how to discover plugins and install them
• Select the Menu item Help > Find and Install

• Select  Search for new features to install and press the  Next button

• Normally you can select one of the default options but for performance reasons we 
will use a update site that is on the local hard drive.  The update site I am providing 
is the combination of the uDig 1.1 Discovery Site and the UWB update site.  In the 
future you may use those sites.

• Press the New Archived Site... button
•
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• Select the update site zip file

• The default is acceptable but to make the site more recognizable it is 
recommended that you enter a more readable name: Foss4G UpdateSite.

• Press the OK button
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• Press the Finish button

• Check the Foss4G UpdateSite element.  You do not need to expand the tree but to 
see what you are installing you may want to.
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• Select the I accept the terms in the License Agreement radio button and press the 
Next button

• Press the Finish Button
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• Wait for the files to download (should be very quick) and press Install All

• Press the Yes button

Now there are new features with new functionality available for use in your day to day 
tasks.  
The two features we will use in this lab are the Transform Tool and the Axios Spatial 
Operations suite.  The next two sections are dedicated to getting familiar with using 
these tools.
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4 Fixing your data

In this section we have a specific task.  We have a shapefile (SOU-outline.shp) that has 
been digitalized in accurately.  The goal is to fix the data.

• Create a new map
• Add a layer that we know is accurate.  We wil use the sou_boundaries from the 

postgis.  Since we have previously loaded it we can drag the layer from our Catalog
• Another option if we have many datasources in our catalog is to use the Search 

view to search the catalog.

• Add SOU_boundaries from the embedded web browser.
• You should now have two layers in your map
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• Notice that the two layers are not aligned.  The line layer is the correct layer.  We 
need to transform the large polygon layer to fit the line layer.

• The transform tool is an excellent choice for this category of problems.
• Make sure that the SOU_outline layer is selected in the Layers view

• Press the  button in the tool bar to begin.
• Select SOU_outline as the source layer.  (The dialog allows a transformation to be 

constructed from an existing vector layer or create a new vector layer.)
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• Press the Add Vectors button
• This will take you back to the Map and allow you to create vectors that indicate 

how the layer needs to be transformed.  
• You can use the zoom and pan tools to move into the map so you can accurately 

add the vectors.  
• Zooming also be done with the mouse scroll wheel and panning holding button 3 

and dragging the map (if the mouse has 3 buttons)
• A third way to zoom is to press the CTRL + and CTRL - key combination.  CTRL 

ARROW can be used for panning
• Add Vectors from SOU_outline to the corresponding point on the sou_boundaries 

layer.
• IMPORTANT the direction of the vectors are very important if they are drawn the 

wrong direction then the layer will be transformed in the opposite direction from 
what is required.

• If you make a mistake you can:
• Use CTRL-Z to undo.

• Use the edit tool  to move the vertex.

• Use the delete tool  to delete a line.
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• I have restyled the vector layer so the vectors are in red for clarity.  The vectors in the 
layer always start at the border of SOU_outline and end at on the edge of 
sou_boundaries.

• Double click the mouse with the Create Line tool enabled to exit vector creation mode.

• Select Rubber Sheet radio button.
• Press the Transform button.  This will perform the transformation

• uDig follows a non-destructive principal.  This means that all major transformations 
will result in a new layer with the resulting transformation.

• In the current version the new layer is an in memory layer which means that the 
memory requirements of the transformation must be considered.  (The next 
version will remove this constraint)
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• The following image shows the resulting map (the colors may differ)

• Turn off all layers except sou_boundaries and SOU_outline_trans

• The map should now be as follows: 

•
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• To save your map press CTRL-S or File > Save

• Select the directory to save the file.  (Defaults to your workspace)
• Uncheck SOU_outline_vectors (Unless you want to use the same transformation 

at a later date)
• You my choose an alternative Projection for the output file if you desire, the 

layer will be transformed to that projection
• Press the Finish button

Congratulations you have vastly improved the accuracy of that layer.
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5 Looking at animals

In this section we will look at a layer that captures animal sightings and perform some 
analysis on the data to see if any trends can be detected.  In the process we will create 
several new layers and even write out some of the data to our postgis.

The Data we will look at is SOU-animals.  
• Create a new map
• Drag the SOU-animals link to the map.

• The simplest (and often most effective) thing to do is apply a thematic style to the 
data.  
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Lots of style

• Create a style that applies to the type attribute 
• I am assuming that you have done this before so I am going through the 

steps very quickly.  If you do not know you can reference Walkthrough 1.
• Select the Layers view
• Press the Layer > Change Style button 
• Click the Theme option in the list on the left
• In the Attribute drop box select type
• Ensure that 3 classes are selected
• Ensure that the Unique Values break is selected
• Select the Dark color scheme.
• Press the OK button
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• The map should now clearly show the areas the different animals inhabit.
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Exploring the table view
• We could label the points but instead we will play with the table view a little in order 

to learn more about the animal populations.
• Select the Table view
• The following dialog will appear.  Close the dialog because we know the layer is not 

too large.

• Type ele or lep into the text field and press enter
• all the elephant sightings are selected
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• Now we will introduce searching based on CQL.  The Appendix I has links to 
resources on CQL.

• Select CQL in the drop box
• Type animalId<10 in the text field and press enter.

• 11 points are selected

• Press the    button to promote all the selection to the top of the view.  We can 
see that penguins 1 and 2 have had multiple sightings.
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• The   button can be pressed to zoom to the selection.

• Press the   button to go back to the previous map view.
• Select type in the drop box
• Type eleph and press enter
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Axios tools (Spatial operations)

• Select Layer > Spatial Operations from the menu

• The Spatial Operations view will open.
• Ensure Buffer is selected
• Ensure SOU_animals is selected as the source layer

• Set the Result layer to be Polygon

• Press the    button to run the operation.
• As you can see only the selected features are buffered
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• Create a 3 class style for the elephants
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• In the table view select animalId and do a search for 101.  

• The elephant 101 seems to stay in the same location.

• Search for elephant 101

• This elephant likes to walk
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• The dissolve operation will combine all the selected polygons together. The disolve 
property determines which polygons are joined

• Select Dissolve
• Select Buffer 1
• Select animalId

• Since we had only had elephant 100 selected there is only one polygon
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• Select the SOU_animals layer again and search for Bat

• Select Buffer in the Spatial Operations view

• Switch to the Advanced tab
• Check Merge geometries
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• Run the operation.  
• In certain circumstances this is the same as running the Buffer and dissolve (but 

not all cases)

• Run the same operation with Penguin selected in the table view
• Turning off the non-buffer layers results in the following map
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Postgis and copying features
• Instead of saving the buffered layers to shapefiles as is the default, we are going to 

create a new layer in postgis and copy the layers into the postgis.
• Open the Catalog view
• Right-click on the Postgis localhost entry and select Operations > Create Feature 

Type

•
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• In the Create New Layer dialog set elephant100 as the feature type name (value in 
the text area

• Set the name of the first attribute to be type
• Set the Type of the geometry attribute to be Polygon

• Create a new attribute by pressing the  button
• The attribute should have the Name animalId and Type Integer
• Press the OK button

• Select the new layer and add it to a new map
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• Change back to the SOU_animals map
• Select Dissolve_1

• Select the elephant 100 polygon

• Copy the polygon
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• Change back to the elephant100 map
• Paste the polygon into this map

   

• Commit the change 

• Clear the selection by ensuring that the map editor/view is selected
• Select the Edit > Clear Selection menu item
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Custom Graphics
Now for no good reason we are going to pretty up our layer by adding an image of an 
elephant to our elephant polygon.  
The real reason for this section is to introduce the Styled Layer Descriptor declaration of 
styles.  Styled Layer Descriptor (SLD) is a standard created by the OGC for describing 
how to style/present a layer.  Using the uDig user-interface only a small part of the SLD 
parameters can be modifed.  The XML view is provided to allow knowledgeable users 
declare very complex styles.  For more information on SLD you can download the 
specification at:  http://www.opengeospatial.org/standards/sld

• Open the style dialog and change to the XML view

• Find the <Rule> tag and place the cursor before the tag.
• Paste the following test at the cursor 

• NOTE:  There are two lines that have wrapped.  They must be on one line.  I have 
hi-lighted the two lines. 

• NOTE:  The url (hi-lighted in red) must be replaced with the path to the 
elephant.png file

<sld:Rule> 
  <sld:Name>name</sld:Name> 
  <sld:Title>title</sld:Title> 
  <sld:Abstract>Abstract</sld:Abstract>
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  <sld:MaxScaleDenominator>1.7976931348623157E308</
sld:MaxScaleDenominator> 
  <sld:PointSymbolizer> 
    <sld:Graphic> 
      <sld:ExternalGraphic> 
        <sld:OnlineResource xmlns:xlink="http://www.w3.org/1999/xlink" 
xlink:type="simple" xlink:href="file:c:\udiglab\elephant.png"/>
        <sld:Format>image/png</sld:Format>
      </sld:ExternalGraphic> 
      <sld:Opacity> 
        <ogc:Literal>1.0</ogc:Literal> 
      </sld:Opacity> 
      <sld:Size> 
        <ogc:Literal>48</ogc:Literal> 
      </sld:Size> 
      <sld:Rotation>
        <ogc:Literal>0.0</ogc:Literal> 
      </sld:Rotation> 
    </sld:Graphic>
  </sld:PointSymbolizer> 
</sld:Rule>

• Press the OK button.  
• There should be small image of an elephant in the center of the polygon.
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Converting Polygons to Lines
It is possible to convert a Polygon to a LineString by pasting the polygon into a line layer

• Create a new Layer.  
• Name the layer Penguin line
• The attribute can 

• The geometry type can be LineString or MultiLineString

  

• Switch back to the SOU_animals map
• Select the Penguin polygon and copy it
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• Change to the elephant100 map
• Ensure that the PenguinLine layer is selected and paste the polygon onto the layer
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6 Adding new attributes 

In this section we will add two new attributes to an existing layer.  One attribute will be 
the computed area of the feature and the other will be a second geometry, the centroid 
of the geometry.

• Create a new map from the SOU-7_UTM35 link in the embedded catalog.

• Select the layer in the Layers view
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• The Reshape Dialog will by default do a direct copy from one layer to another with all 
attributes.  The new layer is in the Scratch service which is temporary and needs to 
be saved.

• Add the two new attributes:

AREA=area(the_geom)
CENTROID=centroid(the_geom)

• Change the combo so the new layer will be added to the map
• If this is not done the new layer can be found in the local catalog as a child of the 

Scratch service

  Foss4G 2008 uDig Lab

1.0 / 16.09.2008 / JER   49/3
© 2008 camptocamp SA / 



• Select the new Layer and inspect it in the Table view.
• IMPORTANT:  The CENTROID attribute is not show because the Table view hides 

geometries in order to reduce the amount of memory required to display the 
features.

• The Feature type of the new layer can be inspected by viewing the layer’s properties.
• Right click on the layer and select Properties
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Appendix I -- CQL Resources

• Examples on the GeoTools website: GeoTools CQL Examples
• Examples on the uDig website: uDig CQL Examples
• OGC Catalog Specification contains the CQL specification.  
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