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1 GOALS

In this workbook we are going to cover two major topics. The first is a tour of Web Feature 
Server functionality using a local GeoServer installation. We will use a WFS to edit both 
feature geometry and feature attributes. We will also show how to export information out of 
a WFS using both a local shape file and the system clip board.

The rest of the workbook is devoted to working with information. We will create a new 
feature type by hand, and work with a range of feature creation and editing tools. Finally we 
will save the result to a new file.
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2 WMS AND WFS INTEGRATION

In this section we will use uDig to display contents from our local Web Feature Server. We 
will also make use of some of the more interesting selection features.

1. Start uDig, under the File menu select New-> New Map to create a new map.

2. Make sure your local GeoServer is started and ready to go. You can run GeoServer from 
the Start menu.

3. Navigate to that GeoServer Welcome page:
http://localhost:8080/geoserver/

4. Drag and Drop the WMS  Capabilities link on to your Map.
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5. This will bring up a Wizard allowing you to choose which Layers you wish to see. 
Select tasmania_state_boundaries_Type and tasmania_cities_Type and the press the 
Finish button.

6. Select Navigation > Show All from the menu bar.

7. Move tasmania_cities_Type to the top of your layers view.
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8. Drag and Drop the WFS Capabilities link on to your Map.

9. This will bring up a Dialog allowing you to choose which Layers you wish to see. 
Select tasmania_roads_Type and tasmania_water_bodies_Type and press the Finish 
button.

10. Select the Map in the projects view and choose File->Rename menu item.

Walkthrough 2 6/30



11. Rename to Tasmania.

12. You can compare your map with what is shown on the web

○ GeoServer 1.4 with MapBuilder
http://localhost:8080/geoserver/wfs-t_demo/index.html

○ GeoServer 1.5 with Open Layers
http://localhost:8080/geoserver/wfst_demo/wfs-t.html         

○ GeoServer 1.6 with Open Layers
http://localhost:8080/geoserver/www/wfs-t.html

Walkthrough 2 7/30

You may wish to  

adjust the styles  

so that lakes are 

blue as shown 

in the picture.

http://localhost:8080/geoserver/www/wfs-t.html
http://localhost:8080/geoserver/wfst_demo/wfs-t.html
http://localhost:8080/geoserver/wfs-t_demo/index.html


3 EDITING GEOMETRY WITH WFS

We will use the Edit Geometry tool to move the road around the lake.

1. Zoom into the road that is crossing the lake in the center of the country (draw a box 
between the two arrows).

2. Select tasmania_roads_Type in the Layers view.

3. Change to the Edit Geometry tool from the tool bar
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4. Use the Edit Geometry tool to select the road crossing the lake.

The road will change color and develop “vertex handles”.

5. Move the vertex handles so the road does not enter the water.

6. Add new vertices by switching to the Add Vertex tool:
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7. You can click any where on the road to add a new vertex.

8. You can use Undo and Redo in the Edit menu as required.

9. Press the Commit Changes button in the tool bar to send your changes off to the Web 
Feature Server.

10. Your line has now been moved.
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11. You can now refresh your web page to confirm that your changes have been made.

○ GeoServer with Open Layers
http://localhost:8080/geoserver/www/wfs-t.html   

○ GeoServer 1.5 with Open Layers
http://localhost:8080/geoserver/wfst_demo/wfs-t.html

○ GeoServer 1.4 with MapBuilder
http://localhost:8080/geoserver/wfs-t_demo/index.html

12. You can edit many Features at once, from different layers, or from different sources of 
data. Pressing Commit Changes will send off all the changes made in the current map.
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4 WORKING WITH ATTRIBUTES

In this section you will learn how to edit an Attribute, along the way we will explore the use 
of styling.

To start out with lets figure out the name of that city:

1. Select Navigation > Show All from the menu bar.

2. Select the tasmansia_cities_Type in the Layers View.

3. Select the Edit > Delete command from the menu bar

4. In the Catalog view expand the My GeoServer WFS entry and select 
tasmania_cities_Type.

5. Right Click and select Add to Current Map.

6. Right click on tasmania_cities_Type in the Layers view, and click on Change Style.
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7. This opens the Style Editor. Select “Simple” from the list on the left hand side, and 
place a check next to “Label” to enable labeling.

8. After making changes, hit the Apply button to update the map, you can experiment with 
the settings and press close when you are finished.

9. Ensure that tasmania_cities_Type is still selected in the layers view, and select the 
Table view.

10. The first time you use table view you will need to accept a warning that all the features 
will be loaded into memory. 

11. The Table view shows all the features for the current layer.
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12. Go ahead and rename the city after yourself. Change the CITY_NAME attribute and you 
can watch the map update.

13. You may also be interested in looking at the details for your city. Start by switching to 
the Edit Geometry tool.

14. Click on the your city with the Edit Geomtry tool (it will turn yellow in the table view). 
Right click on the city and choose to edit the city with the Default Feature Editor.

15. Press the Commit Changes button, in the tool bar, to send your changes off to the Web 
Feature Server.
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5 EXPORTING TO SHAPE FILE

In addition to editing content from many sources, you can also export content to a shapefile.

1. With the tasmania_roads_Type selected, choose File > Export from the menu bar

2. Select the Resource to Shapefile and press Next

3. Your New Tasmania layer will be available for export, you can see that it is in the 
“WGS84” projection.

4. Press Finish to save the file to disk.
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6 TAKE A BREAK!

Wow that was a lot of content, lets take a break and go over some ideas you can try at home.

• The OpenLayers (or MapBuilder) applications also include the ability to edit, see if 
you can edit something in the browser and get the change to show up in uDig.

• There are additional Web Feature Servers listed in the Web Catalog. Try 
downloading some content and seeing what you can learn.

• Advanced: GeoServer 1.4 includes a validation engine, see if you can set up a rule to 
prevent roads from being drawn across lakes in the future.

Okay lets move on.
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7 CREATING FEATURE TYPE

We are going to create a new feature type to experiment with some of the more interesting 
edit tools.

1. Create a New Map

2. Rename the map to “New Tasmania”

3. Add the  “tasmanian roads.shp” file you created previously. You can drag and drop the 
file onto the map, or use Layer > Add from the menu bar.

4. Select the Layer -> Create command from the menu bar.

5. Replace “New Feature Type” with “Lake”.

6. Change the type of the “the_geom” attribute to MultiPolygon.
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7. Click Add Attribute button.

8. Select your new attribute and change the Type to “Integer”.

9. Change the name of the attribute to “type”

10. Press OK button

11. Your Lake type has been added to the scratch area of the Catalog.
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8 COPYING CONTENT

Now that we have created a new feature type, we can use cut and paste to grab geometry 
content from our WFS. This is different from the export we did earlier in that we are using 
our layer type.

1. Change to Tasmania map and select Navigation->Show All in the menu bar. In the 
Layers view make sure that  tasmania_water_bodies_Type is selected as shown below.

2. Select Box Selection from the tool bar.
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3. Use the Box Selection tool to draw a box around all the lakes. The lakes will change 
color when selected.

4. Select Edit->Copy from Edit menu. These lakes will be placed onto the clipboard.

5. Switch over to the New Tasmania map. Ensure your select Lake layer is selected in the 
layer view, and right-click mouse button to select Paste.

6. Press commit to write these new features into your Scratch layer. 

Walkthrough 2 20/30

You can paste  

geometry into  

other 

applications as 

either GML or 

WKT.



9 HOLE CUTTER

In this section we will cover how to create a hole in a polygon.

1. Open the New Tasmania map and zoom to lake shown below.

2. Press the drop arrow to show all the tools in the edit category. Select the Hole Cutter 
tool from the list.
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3. Use the hole cutter to draw a polygon within the lake. 

4. Press Enter, or click on the first vertex, to create the island.

5. Press the Commit button in the toolbar.
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10 CREATE GEOMETRY

The second category of tools involves creating geometry, we will cover line and polygon 
creation and “vertex snapping”.

1. Select tasmanian roads in the layer view.

2. Choose the Create Line Tool from the create category. 

3. Draw a road on the northern part of the island, once again Enter to indicate that you are 
finished your line.

4. You have just created a new road, remember to press commit in the tool bar to write 
your change to the shape file.

5. Change to the Lake layer in the layer view.
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6. Select the Create Polygon Tool.

7. Enable snapping by pressing CTRL+SHIFT+S until Snap to features in current layer 
is displayed in a dialog.

8. Draw a polygon, close to a feature, as you draw close to another polygon you can watch 
how snapping effects the drawing process.

9. You can complete your polygon by ending it on the vertex that started the polygon.

10. Please press the commit button in the toolbar.
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11 CHANGING SNAPPING BEHAVIOR

The snapping choices included with uDig are as follows:

No Snapping Snapping is turned off by default.

Selected Features Snap to a vertex in a selected feature.

Current Layer Snap to a vertex in the current layer

All Layers Snap to a vertex in any layer

Grid Snap to the nearest grid intersection

There is two different ways to change the snap behavior:

1. In the Edit Tool Preferences   which can be found in the Window > Preferences menu.

2. While an edit tool is active press CTRL+SHIFT+S. This will cycle through the available 
snap behaviors. A small pop-up will display the new behavior.
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12 DELETE FEATURE TOOL

1. To delete the feature just created select the Delete Feature Tool.

2. Click on the newly created feature and it will be deleted.
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13 FILL TOOL

The Fill tool fills spaces that are not occupied by existing features.

1. Select the Fill Area Tool.

2. Draw a Polygon that goes through some existing features.

Walkthrough 2 27/30



3. You can select the polygon to show its shape, change to the select tool and click on the 
Polygon to select it.

4. You can see that this is in-fact a multi polygon; a single feature made up of separate 
shapes on the map.
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14 SAVE 

We are now going to save the “Scratch” layer we have been working with.

1. Please press the Save button in the tool bar (or choose save from the File menu).

2. Ensure that your scratch layer Lake is selected and press Finish.

3. A new shapefile has been created in the directory indicated, you can see this file in your 
catalog.

4. Your map has been updated to use your new layer, you can verify this by right clicking 
on your Lake layer and checking its Properties.

Walkthrough 2 29/30



15 WHAT TO DO NEXT

Where to go from here? Try out the following:

• You can use the Reshape operation reorder and rename attributes and even create 
new ones using simple formulas

• Enable Advanced Editing Tools in Windows > Preferences and see what ideas the 
developers are considering. You will need to restart uDig for the settings to take 
effect.

You can define your own issues by right clicking on a selected Feature. In a work 
group setting your team can use a shared issues list to track and review each failure 
in turn.

• The uDig community site has additional editing tools.
Try out the tools provided by Axios.

What ideas do these exercises give you? How can you use PostGIS, GeoServer and uDig in 
your organization?
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