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1 Introduction

Welcome to the User-friendly Internet Desktop GIS (uDig) application!

uDig is collaborative effort brought together by a diverse project management committee 
from organizations across the world:

• Andrea Antonello, HydroloGIS   (Italy)

• Jesse Eichar, Camptocamp   (Switzerland)

• Jody Garnett,  LISAsoft   (Australia)

• Mauricio Pazos Spain)

uDig was originally started by Refractions Research   in Canada with funding from 
GeoConnections   Canada.

uDig is intended to be used in conjunction with your existing investment in spatial 
information. We are of the opinion that data (your data) is what is important. To that end we 
support a wide range of formats, compatibility with a range of spatial databases and 
accessing of information services such as WMS and WFS. This information is combined with 
excellent desktop integration.

The use of an open source license (LGPL  ) allows the uDig project to be used by your 
organization with no per seat license.  Any fixes you make to the core uDig codebase; do 
have to be passed on to your users. May we recommend submitting a patch as an easy way 
to accomplish this goal.

For more information and a selection of case studies:

• http://udig.refractions.net/files/tutorials/uDigCaseStudies.pdf  

• http://udig.refractions.net/gallery/   

In addition to supporting an open source license, uDig is also offers an open development 
model with clear procedures allowing your team to take part.
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http://www.hydrologis.com/
http://udig.refractions.net/gallery/
http://udig.refractions.net/files/tutorials/uDigCaseStudies.pdf
http://www.opensource.org/licenses/lgpl-2.1.php
http://www.geoconnections.org/
http://www.refractions.net/
http://www.lisasoft.com/
http://camptocamp.com/


2 Installing and Running The uDig Application

In this section, you will install and run the Eclipse Application, which will be used for viewing 
map information.

Windows install:

1. Double-click the installer.

2. The installer will allow you  to install uDig into the directory of your choice.

3. We have a number of license agreements to click through.
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If you are in a 
workshop your 
instructor has 
included the uDig 
installer DVD or 
flash drive.

uDig is released 
with a business 
friendly LGPL 
license.

ECW/JP2 support 
is freely available 
to desktop 
applications.



4. By default uDig will be installed into your Program Files directory.

5. Shortcuts will be created in your start menu.

6. Please wait while uDig is installed.
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7. Congratulations you have installed uDig!

• We have a known issue telling Windows 7 that the installation was successful. Please 
click “This program installed correctly”.
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3 Welcome

Now that everything is installed we can start up the application for the first time.

1. After completing the installation, run the uDig application from the Windows Start-
>Programs menu.

2. Initially you are presented with the uDig workbench. The uDig workbench consists of a 
number of panels called views.

3. The Welcome view runs along the right hand side of the screen. This view contains:

• a link to the Getting Started  tutorial from the online documentation.
We cover the use of the online documentation in the next section

• a link to the Official Website 

4. To close the welcome view click the x next word welcome.
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You can return to 
the welcome 
screen at any 
time using the 
Help menu.



4 Online Documentation and Tutorials

In this section you will open up the online tutorial, and access reference information.

1. Open up the Help menu and select  Help Contents

2. The windows firewall will need to allow the help application to startup.

3. This will bring up the online help system; the help system is a web application that 
makes use of a Contents view to allow you to navigate between Pages.

 Show in Table of Contents find your place in the table of contents

4. The Contents view organizes Pages into Books. The following books are included with 
the uDig application

• User Guide

• Live User Guide – live access to the uDig web site

Additional books may be available depending on the community plug-ins you have 
installed.
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You can access 
the tutorials 
directly by 
pressing “Getting 
Started” on the 
welcome screen.

The Live Users 
Guide is a “wiki”  
allowing any 
member of the 
community to 
update the 
documentation.



4.1 HELP CATEGORIES

You can access additional reference information in the following categories:

• Getting Started

• Concepts

• Tasks

• Reference
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5 The Workbench

Before we start playing with maps, let’s take a look at the default layout of the uDig 
workbench and what some of the key components are.

Shown below is a typical session of uDig with the Map, Projects, Layers, and Catalog views 
labeled.  These views will be described further as we demonstrate their uses.
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catalog viewlayer view

Map editorprojects view



6 Connecting to a Web Map Server

In this section you will learn how to drag and drop a Web Map Server (WMS) link into uDig 
for the purpose of viewing its layers.

1. There are many ways to load map data into uDig, including drag and drop.  To drag a 
Web Map Server (WMS) link into uDig, open up a web browser.

2. Please connect to the Walkthrough 1 page with your web browser:

• http://udig.refractions.net/confluence/display/EN/Walkthrough+1   

3. Click and drag the DM Solutions WMS link from the web page onto the Map Editor on 
the left, and drop it there.
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If working with 
your windows 
maximized:
1) Drag from the 
web browser
2) Hover on the 
uDig application 
in the windows 
task bar to 
switch 
applications
3) Drop into the 
Map Editor.

http://udig.refractions.net/confluence/display/EN/Walkthrough+1


4. The Add Layers wizard will appear asking you what layers from this WMS you want to 
show in your map. Select  Elevation/Bathymetry, Parks, Cities  and press the Finish 
button.

5. The map layers will now render in the Map view.  Notice the bottom right corner of the 
uDig Application will display a processing notice while it is requesting and drawing the 
layers.
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You can press on 
the button next to  
the progress 
monitor to watch 
detailed 
information (and 
cancel) rendering 
requests.

rendering progress



6. When the layers are done rendering, the Map view will display the visible layers

7. Now that you have some data on screen try the following tools:

–  Zoom Tool: (keyboard short cut Z)

Click or drag the left button to zoom in, or right button to zoom out.

–  Pan Tool: (keyboard short cut P)

Click and drag to move the display.  

–  Extent Tool: Press to show all layers enabled in the Layers View

8. The Layers view shows the order in which layers are drawn. Please select the Cities 
layer and press the Move up button from the Layer view toolbar.

9. The order is now changed.
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The mouse scroll  
wheel can be 
used to zoom in 
and out quickly 
regardless of the 
currently 
selected tool.

You can also 
drag layers up 
and down in the 
layer view to 
change the order.



7 Adding Layers from the Catalog View

In this section you will learn how to add additional layers to your map from a previously 
connected data source (the DM Solutions WMS).

Adding a Layer from a previously connected WMS:

1. In the Catalog view of uDig expand the Catalog record for the DM Solutions’ WMS 
Demo Server by clicking on the triangle beside the record.  Right-click on Railroads 
and select  Add to Current Map.

2. The new layer will appear in the Layers view, and it will automatically start to render. 
When it finishes rendering, you should see a new borders layer drawn as purple lines.
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3. The catalog also comes equipped with a built in service called “Decoration”. Select 
Decoration > Scalebar  in the Catalog view and drag this layer onto the Map
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Decorations are 
also available  
directly from the 
Layer menu.



8 Adding a Layer from PostGIS

This section shows how you can add a Layer from a PostGIS table. PostGIS is an extension 
to the popular open source PostgreSQL database. uDig handles other databases like Oracle 
and DB2 in a similar manner:

1. In the File menu, select  New -> New Map.

2. In the Projects view, right-click on Map and select  Add.

3. Select PostGIS as the data source and click Next.
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If you are trapped 
behind a firewall  
please feel free to  
skip this section.

The online help 
does have some 
advice about  
“Runnin uDig” 
behind a firewall.



4. Enter the following connection information:
 Host: www      .refractions.net      
 Port: 5432
 Username:demo
 Password:demo
 Store Password:check

Once the connection information is entered press Next.

5. This page lists the databases available to the current user. The www.refractions.net 
does not publish a public list – so rather then choose from a nice easy list we are going 
to have to enter in “demo-bc” by hand.

Database: demo-bc

6. We can now press the List button to list the available tables. Please choose 
bc_hospitals  and bc_municipality and press Next.
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http://www.refractions.net/
http://www.refractions.net/


7. The resource collection page confirms that bc_hospitals and bc_municipality are 
published as spacial layers. We can press Finish to add these layers to our Map.

8. It may take a short while to fully render since you are zoomed out so far.

9. Head on over the the Layer view and right click on bc_hospitals  layer in order to 
choose Zoom to Layer

The map will now zoom in to show the extent of the bc_hospitals layer.

10. You can return to your previous position in the world by selecting Back in the Navigation 
menu.
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You can also 
select Back on 
the tool bar, a  
history of your  
position is kept  
similar to a web 
browser.

Zoom to Layer is 
very useful when 
adding new 
layers that  
happen to be off  
screen or not 
visible at the 
current scale.



9 Working with Files

You can work directly with files from the file system:

1. Please connect to the Walkthrough 1 page with your web browser:

• http://udig.refractions.net/confluence/display/EN/Walkthrough+1     

2. Click on the data “data download” link and save the zip file to your local computer.
At the time of writing the file was:

• http://udig.refractions.net/files/data/data_1_2.zip  

3. Unzip the download to create your data directory. The 7-Zip application is 
recommended.

4. Drag and Drop the file bc_border.shp onto your open Map5

5. This provides a bit of context for your PostGIS layers. When working with uDig you will  
often find yourself combining information from several different sources.
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You instructor has  
placed the data 
directory on your  
dvd – please copy 
this folder to your  
machine prior to  
use.

http://udig.refractions.net/docs/data-v1_1.zip
http://udig.refractions.net/confluence/display/EN/Walkthrough+1


10 Import Directly to The Catalog

Earlier we learned how to work with content from the Catalog view, in this section we will  
import content directly into the catalog.

1. On the Catalog View please press the Import button:

2. Select Data and press Next.

3. Please choose Web Map Server  from the list and press Next.
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4. This time we are going to import the JPL World Map Service from the following 
Capabilities document:

• http://wms.jpl.nasa.gov/wms.cgi?Service=WMS&Version=1.1.1&Request=GetCapabilities  

5. Press Finish to import the Web Map Server into the Catalog view.

6. Now that we have imported the WMS into the catalog we can add it to our Map. Please 
Drag and Drop the Blue Marble, Global MODIS derived image layer directly onto Map

7. Earlier we used the the layer view to reorder using the up and down buttons, this time 
we will drag the layers into the right order. Select the Blue Marble layer in the layer 
view and drag it to the bottom of the list.
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You can copy this  
URL from the 
walkthrough 
page.

You can also try 
dragging a layer  
from the catalog 
view directly into 
the layer view.

The JPL server is  
very busy; if the 
layer does not  
render you can 
look for a 
warning in the 
status bar. You 
may try another  
layer or the 
downloaded 
bluemarble.tif

http://wms.jpl.nasa.gov/wms.cgi?Service=WMS&Version=1.1.1&Request=GetCapabilities


11 Themed Data

Some data contains attributes we may use to thematically style a layer. In this section we 
will create a “Styled Layer Descriptor” (SLD) with the uDig SLD Editor in order to interpret 
these attributes:

1. Create a new map using File > New > New Map

2. Select “Map 2” in the project view, and right click to choose Rename.

3. Enter the name “Blue Marble” and press OK.

4. In the Layer menu, select  Add…

5. Choose Files from the provided list and press Next
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6. Select the following files from the data directory:
bluemarble.tif
countries.shp

7. Press Open and both layers will be added and rendered with a default style.

8. The default style for the countries layer is slightly transparent so can see the base 
raster layer.

9. Right click on the countries layer and select  Change Style
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You will need to  
hold down the 
control key when 
selecting multiple  
files.



10. The Style Editor is arranged into a series of pages, you can use the Simple style page 
to add labels to the countries layer.

– Check the box next to Label

– Choose “CNTRY_NAME” from the list.

11. You can press the Apply button to see what your map will look like with labels.

12. Please switch to the Theme style page and select the following options:

• Attribute: POP_CNTRY

• Normalize: SQKM
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You can 
experiment with  
other settings,  
use the Set Font  
button to change 
to a lighter color  
that will show up 
against the WMS 
layer.

These options 
will color the 
countries layer  
by population 
density.



13. Filter the available colour palettes to show a subset of those available:

– Changing from show “All” to show “Sequential”

– Press  the Colour-blind, LCD and CRT buttons

– Select the “light orange to dark red” palette

14. Press the OKbutton
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These options 
show palettes 
which are a ramp 
of color suitable  
for viewing by 
color blind 
people on either  
an LCD or CRT 
monitor.



15. Open up the Layer menu and choose Legend

16. Press the  Mylar button in the Layers View. Select each layer and observe the effect.
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Mylar will fade out  
all the layers 
except for the one 
selected.



17. Double click on the Blue Marble tab at the top of the screen to maximize the editor. Use 
using the zoom tool to explore the world while the editor is maximized.

18. Double click on the “Map tab” at the top of the screen to restore the previous size. You 
can use  Reset Perspective from the Window menu to restore any views you 
accidentally close during experimentation.
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Your layer view is 
still available on 
the left hand side 
of the screen.

Press the button 
to toggle the 
layer view on and 
off as needed.



12 Information Request

In this section, you will learn how to use the Information Tool.

1. Let us open up our first map again, which was labeled Elevation/Bathymetry

2. Let’s zoom to somewhere interesting, like a green park.

3. Select the Parks layer in the layer view
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You can also 
double click on a  
Map to open it.



4. Change to the Info Tool in the tool bar, and click on a Park.

5. The Information View is brought into focus, showing information about the park layer at 
the location you clicked.

6. You can switch to requesting information on another layer on the left pane. Available 
information, if any, is displayed on the right pane.

7. Not all Web Map Servers support the “GetFeatureInfo” operation; as such information 
may not be available for all layers. The application uses a normal browser to display 
HTML content; you can drag the view out of the workbench if you find you need more 
elbowroom.

uDig Walkthrough 1 29/40

You can use the 
keyboard short-
cut ‘i’ to choose  
the info tool



13 Web View

In this section you will learn how to use the embedded web browser:

1. Create a New Map, and press the tab for the Web view (located along the bottom of the 
window near Catalog).

2. Click on the WMS link for dm solutions.

3. The Add Layer wizard will open (uDig can recognize links to spatial content). Choose 
the Parks, Provice, Roads and Cities and press Finish
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You can use the 
Web Catalog with 
your own website 
for easy spatial  
visualization.



14 Re-projection

Since the world is not flat, maps are projected  to line up with a Co-ordinate Reference 
System (CRS).

1. Create a new map using the bc_border, and bc_pubs shapefile and bc_voting areas 
shapefiles.

2. The map will take on the coordinate reference system of the added layers. You can right 
click on bc_border and use Operation > Set Map Projection from Layer  to use “BC 
Albers” - this is an equal area projection.

3. Press the “BC Albers” button to bring up the CRS Chooser.
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4. This brings up the a preference page allowing you to change the Coordinate Reference 
System for your map. Please enter in 4326 and press enter to re-project the map to the 
“World Geodetic System 1984” CRS commonly used to represent lat/lon information.

5. You can have a look at the formal definition of “EPSG:4326 by switching to the “Custom 
CRS” tab
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You can also 
search by name, 
try typing in 
“WGS84” to list  
matching 
projections

The definition is 
provided in “Well  
Known Text” -  
you can use this 
format for your 
own custom CRS.



6. Press the OK button to change the coordinate reference system of your map.
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15 Community

One of the nice things about uDig is the ease to download and install additional plug-ins 

provided by the developer community.

1. Open up Help > Find and Install

2. Select Search for New Features to Install  and press Next

3. Press the New Remote Site button and type the following parameters:
Name: uDig Community Updates
URL:  http://udig.refractions.net/update/1.2/community  
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http://udig.refractions.net/update/1.2/community


4. Check the new uDig Community Updates option and press Finish

5. Please wait while the program checks the update site for new features.
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6. Once the program finishes getting the complete list of plug-ins, you will see something 
like this:

7. Check the latest  es.axios.udig.editingtools  version from the list and press Next.

8. Accept the terms in the license agreement and press Next.
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9. Finally confirm the installation location and press Finish.

10. Many of the community features have not been formally signed, please click Install All 
when presented with a warning.

11. You will need to Restart uDig when the installation finishes.

12. You may have noticed some new options in the toolbar. We are going to test the Merge 
feature.
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13. Load a test layer, like countries, and select the Merge option as shown below.

14. Select some features in your layer.

15. A new View called Merge Tool will appear in the lower box.
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16. Click on the green check on the upper-right corner of the Merge Tool view to run the 
merge of the features. The result will be something like this:  
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16 What to do Next?

Congratulations you have finished the first walkthrough. This is just the start of what uDig 
can do!

• Try out the north arrow – change projections in order to see how it works.

• There is more data available in the data directory - have a look !

• Try right-clicking on a Layer – there is plenty to do (try the operations menu).

• Does your organization publish any spatial information on the web?

• Try out the navigation tools such as Zoom and Pan (the Navigation menu lets you go back 
to previous locations like a web browser).

• Advanced: Use the Style Editor to switch automatically from the bluemarble.tiff to the 
JPL Web Map Server blue marble layer. Switching based on scale allows for performance 
when zoomed out, while still providing full resolution blue marble imagery from NASA 
when you are closer.

• Advanced: Open the Style Editor, have a look at the Advanced ( XML ) page and see 
what you make of it.

Perhaps you have an idea for the tool you always wanted?
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