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1 INSTALLING AND RUNNING THE 
UDIG APPLICATION

In this section, you will install and run the Eclipse Application, 
which will be used for viewing map information.

Windows install:

1. Double-click the installer udig1.1.exe (located in the same 
directory as this walkthrough)

2. The installer will allow you  to install uDig into the directory of 
your choice.

3. Agree to the License Agreement – uDig is made available 
under the LGPL.



4. By default uDig will be installed into your Program Files 
directory.

5. Shortcuts will be created in your start menu.

6. Please wait while uDig is installed.



7. Congratulations you have installed uDig



2 WELCOME

1. After completing the installation, run the uDig application from 
the Windows Start->Programs menu

2. Initially you are presented with the welcome screen.

3. The welcome screen contains a link to the Getting Started 
tutorial from the online documentation.

We cover the use of the online documentation in the next 
section



4. The welcome screen contains a link to the Official Website 

5. To continue click on the Workbench arrow in the top right 
corner of the uDig welcome screen.

You can return to the 

welcome screen at any time 

using the Help menu.



3 ONLINE DOCUMENTATION AND 
TUTORIALS

In this section you will open up the online tutorial, and access 
reference information.

1. Open up the Help menu and select Help Contents

2. This will bring up the online help system; the help system is a 
web application that makes use of a Contents view to allow you 
to navigate between Pages.

 Refresh / Show Current Topic
 Can be used to find your place in the table of contents

 Show in Table of Contents
 Can be used to find your place in the table of contents

3. The Contents view organizes Pages into Books. The following 
books are included with the uDig application

• User Guide

• Live User Guide – live access to the uDig web site

Additional books may be available depending on the community 
plug-ins you have installed.

If you have the windows 

firewall enabled you will  

need to allow the help 

application to startup.

You can access the tutorials  

directly by pressing “Getting  

Started” on the welcome 

screen.



3.1 HELP CATEGORIES

You can access additional reference information in the following 
categories:

• Getting Started

• Concepts

• Tasks

• Reference



4 THE WORKBENCH

Before we start playing with maps, let’s take a look at the default 
layout of the uDig workbench and what some of the key components 
are.

Shown below is a typical session of uDig with the Map, Projects, 
Layers, and Catalog views labeled.  These views will be described 
further as we demonstrate their uses.

catalog viewlayer view

Map editorprojects view



5 CONNECTING TO A WEB MAP 
SERVER

In this section you will learn how to drag and drop a Web Map Server 
(WMS) link into uDig for the purpose of viewing its layers.

1. There are many ways to load map data into uDig, including 
drag and drop.  To drag a Web Map Server (WMS) link into 
uDig, open up a web browser.

2. Please connect to the Walkthrough 1 page with your web 
browser:

• http://udig.refractions.net/confluence/display/EN/Walkthrough+1

3. Click and drag the DM Solutions WMS link from the web page 
onto the Layers View on the left, and drop it there.If working with your 

windows maximized:

1) Drag from the web 

browser

2) Hover on the uDig 

application in the 

windows task bar

3) Drop into the Map 

area.

http://udig.refractions.net/confluence/display/UDIG/Walkthrough+1


4. The Add Layers a wizard will appear asking you what layers 
from this WMS you want to show in your map. Select 
Elevation/Bathymetry, Parks, Cities and press the Finish 
button.

5. The map layers will now render in the Map view.  Notice the 
bottom right corner of the uDig Application will display a 
processing notice while it is requesting and drawing the layers.

You can press on the  

button next to the 

progress monitor to  

watch detailed 

information (and 

cancel) rendering 

requests.

rendering progress



6. When the layers are done rendering, the Map view will display 
the visible layers

7. Now that you have some data on screen try the following tools:

•  Zoom Tool: (keyboard short cut Z)
Click or drag the left button to zoom in, or right button to 
zoom out.

•  Pan Tool: (keyboard short cut P)
Click and drag to move the display. 

•  Extent Tool: Press to show all

8. The Layers view shows the order in which layers are drawn. 
Please select the Cities layer and press the Move up button 
from the Layer view toolbar.

9. The order is now changed.

When using the zoom 

or pan tools the mouse 

scroll wheel can be 

used to zoom in and out  

quickly.

You can also drag 

layers up and down in 

the layer view to change 

the order.



6 ADDING LAYERS FROM THE 
CATALOG VIEW

In this section you will learn how to add additional layers to your 
map from a previously connected data source (the DM Solutions 
WMS).

Adding a Layer from a previously connected WMS:

1. In the Catalog view of uDig (center bottom), expand the 
connection you have to DM Solutions’ WMS Demo Server. 
Right-click on the Provincial Borders layer and select Add to 
Current Map.



2. The new layer will appear in the Layers view, and it will 
automatically start to render.  When it finishes rendering, you 
should see black lines representing the provincial borders on the 
map (the new layer).

3. The catalog also comes equipped with a built in service called 
“Map Graphic”. Select Map Graphic > Scalebar in the Catalog 
view and drag this layer onto the Map

Map Graphics are also  

available directly from 

the Layer menu.



7 ADDING A LAYER FROM POSTGIS

This section shows how you can add a Layer from a PostGIS table. 
PostGIS is an extension to the popular open source PostgreSQL 
database. uDig handles other databases like Oracle and DB2 in a 
similar manner:

1. In the File menu, select New -> New Map.

2. In the Projects view, right-click on Map and select Add.

3. Select PostGIS as the data source and click Next.



4. Enter the following connection information:
Host: www.refractions.net  
Port: 5432

Username: demo
Password: demo
Database: demo-bc

5. Once the connection information is entered press Next.

6. Select only the bc_hospitals and bc_municipality data, and 
click Finish.

7. It may take a short while to fully render since you are zoomed 
out so far.

Your instructor has set  

up a local PostGIS for  

you to use:

Host: localhost

Port: 5432

Username: postgres 

Password: postgres 

Database: example

http://www.refractions.net/
http://www.refractions.net/
http://www.refractions.net/


8. Head on over the the Layer view and right click on 
bc_hospitals layer in order to choose Zoom to Layer

9. The map will now zoom in to show the extent of the 
bc_hospitals layer.

10. You can return to your previous position in the world by 
selecting Back in the Navigation menu.You can also select  

Back on the tool bar, a 

history of your position 

is kept similar to a web 

browser.

Zoom to Layer is very  

useful when adding new 

layers that happen to be 

off screen or not visible  

at the current scale.



8 WORKING WITH FILES

You can work directly with files from the file system:

1. Please connect to the Walkthrough 1 page with your web 
browser:

• http://udig.refractions.net/confluence/display/EN/Walkthrough+1

2. Click on the data “data download” link and save the zip file to 
your local computer.
At the time of writing the file was:

• http://udig.refractions.net/docs/data-v1_1.zip  

3. Unzip the download to create your data directory. The 7-Zip 
application is recommended.

4. Drag and Drop the file bc_border.shp onto your open Map

5. This provides a bit of context for your PostGIS layers. When 
working with uDig you will often find yourself combining 
information from several different sources.

You instructor has 

placed the data 

directory in your lab 

folder.

http://udig.refractions.net/docs/data-v1_1.zip
http://udig.refractions.net/confluence/display/UDIG/Walkthrough+1


9 IMPORT DIRECTLY TO THE 
CATALOG

Earlier we learned how to work with content from the Catalog view, 
in this section we will import content directly into the catalog.

1. On the Catalog View please press the Import button:

2. Select Data and press Next.

3. Please choose Web Map Server from the list and press Next.



4. This time we are going to import the JPL World Map Service 
from the following Capabilities document:

• http://wms.jpl.nasa.gov/wms.cgi?Service=WMS&Version=1.1.1&Request=GetCapabilities  

5. Press Finish to import the Web Map Server into the Catalog 
view.

6. Now that we have imported the WMS into the catalog we can 
add it to our Map. Please Drag and Drop the Blue Marble, 
Global MODIS derived image layer directly onto Map2

7. Earlier we used the the layer view to reorder using the up and 
down buttons, this time we will drag the layers into the right 
order. Select the Blue Marble layer in the layer view and drag 
it to the bottom of the list.

You can copy this  

URL from the 

walkthrough page

Try dragging a layer 

from the catalog view 

directly into the layer 

view.

The JPL server is very  

busy; if the layer does 

not render you can look 

for a warning in the 

status bar.  If this  

happens to you please 

try another layer.

http://wms.jpl.nasa.gov/wms.cgi?Service=WMS&Version=1.1.1&Request=GetCapabilities


10THEMED DATA

Some data contains attributes we may use to thematically style a 
layer. In this section we will create a “Styled Layer Descriptor” 
(SLD) with the uDig SLD Editor in order to interpret these 
attributes:

1. In the Catalog view of uDig (center bottom), under the “JPL 
Global Imagery Service” tree, right click on “Blue Marble 
Next Generation, Global MODIS derived image” and select 
Add to New Map.

2. That new map has an awfully long name, select in the project 
view, and right click to choose Rename.

3. Enter the name “Blue Marble” and press OK.

4. In the Layer menu, select Add…



5. Choose Files from the provided list and press Next:

6. Select the following files from the data directory:
countries.shp
clouds.jpg

7. Press Open and both layers will be added and rendered with a 
default style.

8. Drag the clouds.jpg layer to the bottom of the layer view.

9. The default style for the countries layer is slightly transparent 
so you can still see the pretty WMS layer underneath.

10. Right click on the countries layer and select Change Style



11. The Style Editor is arranged into a series of pages, you can use 
the Simple style page to add labels to the countries layer.

• Check the box next to Label

• Choose “CNTRY_NAME” from the list.

12. You can press the Apply button to see what your map will look 
like with labels.

13. Please switch to the Theme style page and select the following 
options:

• Attribute: POP_CNTRY

• Normalize: SQKM

You can experiment 

with other settings,  

use the Set Font  

button to change to a  

lighter color that will  

show up against the 

WMS layer.

These options will  

color the countries  

layer by population 

density.



14. Filter the available colour palettes to show a subset of those 
available:

• Changing from show “All” to show “Sequential”

• Press  the Colour-blind, LCD and CRT buttons

• Select the “light orange to dark red” palette

15. Press the OKbutton

16. Open up the Layer menu and choose Legend

These options show 

palettes which are a 

ramp of color suitable  

for viewing by color  

blind people on either 

an LCD or CRT 

monitor.



17. Press the  Mylar button in the Layers View. Select each 
layer and observe the effect.

18. Double click on the Blue Marble map tab to maximize the 
editor.Try using the zoom tool to explore the world.

19. Double click on the Map tab to restore the previous size. You 
can use  Reset Perspective from the Window menu to restore 
any views you accidently close during experimentation.

Mylar will fade out  

all the layers except  

for the one selected.

Your layer view is  

still available on the 

left hand side of the 

screen.

Press the button to  

toggle the layer view 

on and off as needed.



11INFORMATION REQUEST

In this section, you will learn how to use the Information Tool.

1. Let us open up our first map again, which was labeled 
Elevation/Bathymetry

2. Let’s zoom to somewhere interesting, like a green park.

3. Select the Parks layer in the layer view

 

4. Change to the Info Tool in the tool bar, and click on a Park.

You can use the 

keyboard short-cut ‘i’  

to choose the info tool

You can also double  

click on a Map to  

open it.



5. The Information View is brought into focus, showing 
information about the park layer at the location you clicked.

6. You can switch to requesting information on another layer on 
the left pane. Available information, if any, is displayed on the 
right pane.

7. Not all Web Map Servers support the “GetFeatureInfo” 
operation; as such information may not be available for all 
layers. The application uses a normal browser to display HTML 
content; you can drag the view out of the workbench if you find 
you need more elbowroom.



12WEB CATALOG

In this section you will learn how to use the web catalog:

1. Create a New Map, and press the tab for the Web Catalog view 
(located along the bottom of the window near Catalog).

2. Click on the WMS link for dm solutions.

3. The Add Layer wizard will open (uDig can recognize links to 
spatial content). Choose the Parks, Provincial Border, Roads 
and Cities and press Finish

You can use the Web 

Catalog with your 

own website for easy  

spatial visualization.



13RE-PROJECTION

Since the world is not flat, maps are projected in a Co-ordinate 
Reference System (CRS).  We will now make 2 identical maps, 
perform a re-projection on one, and compare.

1. Please use the Zoom and Pan tools to navigate to British 
Columbia (on the west side of North America). Press the button 
at bottom of Map 3 marked “WGS 84”.

2. This brings up the a preference page allowing you to change the 
Coordinate Reference System for your map. Please enter in 
42304 and press enter to re-project the map to the 
“NAD83/NRCan LCC Canada” CRS.You can also search 

by name, try typing in 

“NAD83” to list  

matching projections



3. You can have a look at the formal definition of “EPSG:42304 
by switching to the “Custom CRS” tab

4. Press the OK button to change the projection of your map.



14COMMUNITY

One of the nice things about uDig is ease of which you can download 
additional plug ins provided by the developer community.

1. Open up Help > Find and Install...

2. Select Search for New Features to Install and press Next

3. Press the New Remote Site button and provide the following:
Name: uDig Community Updates
URL: http://udig.refractions.net/update-community



4. Place a check mark for Community Updates and press Finish

5. Please wait while we check the update site for new features.

6. When we have a complete list you will see a screen similar to 
the following

7. Please place a check next to Visual feature Feature 1.0.0 from 
the list and press Next.



8. Accept the terms of the license agreement and press Next.

9. Finally confirm the installation location and press Finish.

10. Many of the community features have not been formally signed, 
please click Install All when presented with a warning.

11. You will want to Restart uDig when presented the opportunity.



12. You now have a new North Arrow Map graphic available in 
your catalog. Drag and drop it onto your Parks 2 map.

13. You may of noticed an ugly red square in the tool bar, select 
this “tool” and your “North Arrow” layer and you can position 
the arrow on the Map.

14. Community contributions range from small map graphics like 
this to custom editors and additional spatial formats.

You can package up 

uDig with just the 

plugins you need for 

your organization.



15FINISHED ALREADY?

If you finish early here are some challenges.

• There is more data available in the data directory - have a 
look !

• Try right-clicking on a Layer – there is plenty to do (try the 
operations menu).

• Does your organization publish any spatial information on the 
web?

• Try out the navigation tools such as Zoom and Pan (the 
Navigation menu lets you go back to previous locations like a 
web browser).

• Advanced: Open the Style Editor, have a look at the 
Advanced ( XML ) page and see what you make of it.

Perhaps you have an idea for the tool you always wanted?
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